// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<drupal-entity[^>]+></drupal-entity><p> </p>").unwrap();
let string = "</p><drupal-entity data-view-mode=\"oembed_display\"></drupal-entity><p><strong>Designer Crush:</strong></p><drupal-entity data-view-mode=\"oembed_display\"></drupal-entity><p> </p>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}