re = /<drupal-entity[^>]+><\/drupal-entity><p> <\/p>/
str = '</p><drupal-entity data-view-mode="oembed_display"></drupal-entity><p><strong>Designer Crush:</strong></p><drupal-entity data-view-mode="oembed_display"></drupal-entity><p> </p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end