#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\.)(?:cancelled|deliver)\b"
Local $sString = "line1" & @CRLF & _
"line2" & @CRLF & _
"field: [orders.cancelled,orders.delivered,orders.reached" & @CRLF & _
"orders.pickup,orders.time]" & @CRLF & _
"some line" & @CRLF & _
"some line"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")