import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\.)(?:cancelled|deliver)\\b";
final String string = "line1\n"
+ "line2\n"
+ "field: [orders.cancelled,orders.delivered,orders.reached\n"
+ "orders.pickup,orders.time]\n"
+ "some line\n"
+ "some line";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}