re = /(?<=\.)(?:cancelled|deliver)\b/m
str = 'line1
line2
field: [orders.cancelled,orders.delivered,orders.reached
orders.pickup,orders.time]
some line
some line'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end