import re
regex = re.compile(r"(?<=\.)(?:cancelled|deliver)\b", flags=re.MULTILINE)
test_str = ("line1\n"
"line2\n"
"field: [orders.cancelled,orders.delivered,orders.reached\n"
"orders.pickup,orders.time]\n"
"some line\n"
"some line")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")