using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d{9})([0-2]{1})([0-0]{1})([0-3]{1})([0-9]{8})$";
string input = @"00099326620118160014";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}