$re = '/^(\d{9})([0-2]{1})([0-0]{1})([0-3]{1})([0-9]{8})$/';
$str = '00099326620118160014';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);