package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\d{9})([0-2]{1})([0-0]{1})([0-3]{1})([0-9]{8})$`)
var str = `00099326620118160014`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}