import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d*?(?<first>(?<a>\\d)\\k<a>)\\d*?(?!\\k<first>)(?<second>(?<b>\\d)\\k<b>)\\d*$";
final String string = "What should match (where # is just any digit, matching 1 or 2 or not)\n\n"
+ "11722\n"
+ "11227\n"
+ "71122\n\n"
+ "What should not match\n\n"
+ "11711\n"
+ "22227\n"
+ "88888\n"
+ "11x22\n"
+ "1122x\n"
+ "x1122\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}