# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\d*?(?<first>(?<a>\d)\k<a>)\d*?(?!\k<first>)(?<second>(?<b>\d)\k<b>)\d*$"
test_str = ("What should match (where # is just any digit, matching 1 or 2 or not)\n\n"
"11722\n"
"11227\n"
"71122\n\n"
"What should not match\n\n"
"11711\n"
"22227\n"
"88888\n"
"11x22\n"
"1122x\n"
"x1122\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.