re = /^\d*?(?<first>(?<a>\d)\k<a>)\d*?(?!\k<first>)(?<second>(?<b>\d)\k<b>)\d*$/m
str = 'What should match (where # is just any digit, matching 1 or 2 or not)
11722
11227
71122
What should not match
11711
22227
88888
11x22
1122x
x1122
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end