const regex = /^\d*?(?<first>(?<a>\d)\k<a>)\d*?(?!\k<first>)(?<second>(?<b>\d)\k<b>)\d*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d*?(?<first>(?<a>\\d)\\k<a>)\\d*?(?!\\k<first>)(?<second>(?<b>\\d)\\k<b>)\\d*$', 'gm')
const str = `What should match (where # is just any digit, matching 1 or 2 or not)
11722
11227
71122
What should not match
11711
22227
88888
11x22
1122x
x1122
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}