using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G(?!\A)|calculated(?:\s+F)?)\s*\K\S+";
string input = @"calculated 1a5 5W13 153w135 1E55 12_5 1.56 1M55
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}