import re
regex = re.compile(r"(?:\G(?!\A)|calculated(?:\s+F)?)\s*\K\S+")
test_str = ("calculated 1a5 5W13 153w135 1E55 12_5 1.56 1M55\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")