re = /(?:\G(?!\A)|calculated(?:\s+F)?)\s*\K\S+/
str = 'calculated 1a5 5W13 153w135 1E55 12_5 1.56 1M55
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end