const regex = /(?:\G(?!\A)|calculated(?:\s+F)?)\s*\K[\w.]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\G(?!\\A)|calculated(?:\\s+F)?)\\s*\\K[\\w.]+', 'g')
const str = `calculated 1a5 5W13 153w135 1E55 12_5 1.56 1M55 ||
calculated F 1a5 5W13 153w135 1E55 12_5 1.56 1M55
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}