use strict;
my $str = 'calculated 1a5 5W13 153w135 1E55 12_5 1.56 1M55 ||
calculated F 1a5 5W13 153w135 1E55 12_5 1.56 1M55
';
my $regex = qr/(?:\G(?!\A)|calculated(?:\s+F)?)\s*\K[\w.]+/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}