import Foundation
let pattern = #"(?:\G(?!\A)|calculated(?:\s+F)?)\s*\K[\w.]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
calculated 1a5 5W13 153w135 1E55 12_5 1.56 1M55 ||
calculated F 1a5 5W13 153w135 1E55 12_5 1.56 1M55
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)