package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"company"\s*:\s*(\d+)(?:.*?"address1"\s*:\s*"(.*?)")?(?:.*?"country"\s*:\s*"(.*?)")?(?:.*?"Name"\s*:\s*"(.*?)")?`)
var str = `{"company": 123, "irrelevant": "nonsense", "address": {"address1": "123 London Road", "country": "GB"}}
{"company": 456, "irrelevant": "nonsense", "country": "GB", "Name": "Mary"}
{"company": 789, "irrelevant": "nonsense", "address": {"address1": "123 Paris Road", "country": "FR", "Name": "Joe"}}
{"company": 444}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}