// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""company"\s*:\s*(\d+)(?:.*?"address1"\s*:\s*"(.*?)")?(?:.*?"country"\s*:\s*"(.*?)")?(?:.*?"Name"\s*:\s*"(.*?)")?"#).unwrap();
let string = "{\"company\": 123, \"irrelevant\": \"nonsense\", \"address\": {\"address1\": \"123 London Road\", \"country\": \"GB\"}}
{\"company\": 456, \"irrelevant\": \"nonsense\", \"country\": \"GB\", \"Name\": \"Mary\"}
{\"company\": 789, \"irrelevant\": \"nonsense\", \"address\": {\"address1\": \"123 Paris Road\", \"country\": \"FR\", \"Name\": \"Joe\"}}
{\"company\": 444}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}