$re = '/"company"\s*:\s*(\d+)(?:.*?"address1"\s*:\s*"(.*?)")?(?:.*?"country"\s*:\s*"(.*?)")?(?:.*?"Name"\s*:\s*"(.*?)")?/';
$str = '{"company": 123, "irrelevant": "nonsense", "address": {"address1": "123 London Road", "country": "GB"}}
{"company": 456, "irrelevant": "nonsense", "country": "GB", "Name": "Mary"}
{"company": 789, "irrelevant": "nonsense", "address": {"address1": "123 Paris Road", "country": "FR", "Name": "Joe"}}
{"company": 444}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);