import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"company\"\\s*:\\s*(\\d+)(?:.*?\"address1\"\\s*:\\s*\"(.*?)\")?(?:.*?\"country\"\\s*:\\s*\"(.*?)\")?(?:.*?\"Name\"\\s*:\\s*\"(.*?)\")?";
final String string = "{\"company\": 123, \"irrelevant\": \"nonsense\", \"address\": {\"address1\": \"123 London Road\", \"country\": \"GB\"}}\n"
+ "{\"company\": 456, \"irrelevant\": \"nonsense\", \"country\": \"GB\", \"Name\": \"Mary\"}\n"
+ "{\"company\": 789, \"irrelevant\": \"nonsense\", \"address\": {\"address1\": \"123 Paris Road\", \"country\": \"FR\", \"Name\": \"Joe\"}}\n"
+ "{\"company\": 444}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}