const regex = /^\s*(\+[0-9][0-9]\s*|0|)(7.*)/mgi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*(\\+[0-9][0-9]\\s*|0|)(7.*)', 'mgi')
const str = `+41 79 123 456 78
+417612345678
076 123 456 78
07812345678
7712345678
+41 47 123 456 78
+413212345678
021 123 456 78
02212345678
3412345678`;
const subst = `$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);