// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mix)^\s*(\+[0-9][0-9]\s*|0|)(7.*)").unwrap();
let string = "+41 79 123 456 78
+417612345678
076 123 456 78
07812345678
7712345678
+41 47 123 456 78
+413212345678
021 123 456 78
02212345678
3412345678";
let substitution = "$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}