# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^\s*(\+[0-9][0-9]\s*|0|)(7.*)
"""
test_str = ("+41 79 123 456 78\n"
"+417612345678\n"
"076 123 456 78\n"
"07812345678\n"
"7712345678\n\n"
"+41 47 123 456 78\n"
"+413212345678\n"
"021 123 456 78\n"
"02212345678\n"
"3412345678")
subst = "$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.IGNORECASE | re.VERBOSE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.