using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d+\.?(?:\d+)?[KkMm]?(?<!\.[KkMm])$";
string input = @"400K
4.2.K
4.3K
3.2M
300000
4....K
4K
500.
300.K";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}