re = /^\d+\.?(?:\d+)?[KkMm]?(?<!\.[KkMm])$/m
str = '400K
4.2.K
4.3K
3.2M
300000
4....K
4K
500.
300.K'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end