const regex = /^\d+\.?(?:\d+)?[KkMm]?(?<!\.[KkMm])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d+\\.?(?:\\d+)?[KkMm]?(?<!\\.[KkMm])$', 'gm')
const str = `400K
4.2.K
4.3K
3.2M
300000
4....K
4K
500.
300.K`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}