use strict;
my $str = '400K
4.2.K
4.3K
3.2M
300000
4....K
4K
500.
300.K';
my $regex = qr/^\d+\.?(?:\d+)?[KkMm]?(?<!\.[KkMm])$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}