const regex = new RegExp('\\d{2}\\/\\d{2}\\/\\d{2}(?:(?!\\d{2}\\/\\d{2}\\/\\d{2}).)*string.*?\\d{2}\\/\\d{2}\\/\\d{2}', 'gms')
const str = `01/20/20
string
01/21/20
01/20/20
this isn't the phrase you're looking for
01/21/20
string`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}