import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(°\\s?)?(\\d+(?:\\.\\d+)?+°?+\\s?[fF])";
final String string = "23°F\n"
+ "23° F\n"
+ "23°f\n"
+ "23° F\n"
+ "°23f\n"
+ "°23F\n"
+ "23.3 F\n"
+ "23.3f\n"
+ "212°F\n"
+ "° 27 f";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}