$re = '/(°\s?)?(\d+(?:\.\d+)?+°?+\s?[fF])/';
$str = '23°F
23° F
23°f
23° F
°23f
°23F
23.3 F
23.3f
212°F
° 27 f';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);