const regex = /(°\s?)?(\d+(?:\.\d+)?+°?+\s?[fF])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(°\\s?)?(\\d+(?:\\.\\d+)?+°?+\\s?[fF])', 'g')
const str = `23°F
23° F
23°f
23° F
°23f
°23F
23.3 F
23.3f
212°F
° 27 f`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}