re = /(°\s?)?(\d+(?:\.\d+)?+°?+\s?[fF])/
str = '23°F
23° F
23°f
23° F
°23f
°23F
23.3 F
23.3f
212°F
° 27 f'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end