#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\[(?!\^)(.*)\]: <?((?:[a-zA-Z]\:|\\\\[^\/\\:*?"<>|]+\\[^\/\\:*?"<>|]+|\.{1,2})(?:\\[^\/\\:*?"<>|]+)+(?:\.[^\/\\:*?"<>| ]+)|(?:\.{1,2}|~){0,1}(?:(?:\/|\\)(?:[a-zA-Z0-9._-])*)+|\w+:(?:\/?\/?)[^\s>]+)>?(?:\n? +["'(](.*)["')])?(?: \{(.*)\})?"
Local $sString = "|(?:\\|\/" & @CRLF & _
"[my label 1]: /foo/bar.jpg "My title, optional"" & @CRLF & _
"[my label 2]: ~/foo/bar.png "My title, optional"" & @CRLF & _
"[my label 1]: ~/foo/.img "My title, optional"" & @CRLF & _
"[my label 1]: ~/.img "My title, optional"" & @CRLF & _
"" & @CRLF & _
"[my label 2]: /foo" & @CRLF & _
"[my label 3]: https://fsf.org (The free software foundation)" & @CRLF & _
"[my label 3]: (The free software foundation)" & @CRLF & _
"" & @CRLF & _
"[my label 4]: /bar#special 'A title in single quotes'" & @CRLF & _
"" & @CRLF & _
"[my label 1]: ./foo/bar.html "My title, optional"" & @CRLF & _
"[my label 2]: ../foo/bar.html" & @CRLF & _
"[my label 1]: ./foo/bar.html "My title, optional"" & @CRLF & _
"[my label 3]: https://fsf.org (The free software foundation)" & @CRLF & _
"[my label 4]: /foo/bar.html#special 'A title in single quotes'" & @CRLF & _
"" & @CRLF & _
"[my label 5]: <http://foo.bar.baz>" & @CRLF & _
"" & @CRLF & _
"[my label 3]: https://fsf.org" & @CRLF & _
" "The free software foundation"" & @CRLF & _
"" & @CRLF & _
"[my label 5]: <http://foo.bar.baz>" & @CRLF & _
"" & @CRLF & _
"[my label 1]: ..\foo\bar.html "My title, optional"" & @CRLF & _
"[my label 1]: C:\foo\bar.html "My title, optional"" & @CRLF & _
"[my label 1]: .\foo\bar.html "My title, optional"" & @CRLF & _
"[my label 1]: \\unc.server.tld.co\path\to\file.ext "My title, optional"" & @CRLF & _
"" & @CRLF & _
"[my label 2]: C:\foo" & @CRLF & _
"[my label 3]: https://fsf.org (The free software foundation)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[my label 2]: /foo" & @CRLF & _
"[my label 3]: https://fsf.org (The free software foundation)" & @CRLF & _
"" & @CRLF & _
"(?:\.{1,2}|~){0,1}(?:(?:\/|\\)(?:[a-zA-Z0-9._ -])*)+" & @CRLF & _
"" & @CRLF & _
"^\[(?!\^)(.*)\]: <?((?:[a-zA-Z]\:|\\\\[^\/\\:*?"<>|]+\\[^\/\\:*?"<>|]+|\.{1,2})(?:\\[^\/\\:*?"<>|]+)+(?:\.[^\/\\:*?"<>| ]+)|(?:\.{1,2}|~){0,1}(?:(?:\/|\\)(?:[a-zA-Z0-9._ -])*)+|\w+:(?:\/?\/?)[^\s]+)>?(?:\n? +["'(](.*)["')])?(?: \{(.*)\})?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")