using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\[(?!\^)(.*)\]: <?((?:[a-zA-Z]\:|\\\\[^\/\\:*?""<>|]+\\[^\/\\:*?""<>|]+|\.{1,2})(?:\\[^\/\\:*?""<>|]+)+(?:\.[^\/\\:*?""<>| ]+)|(?:\.{1,2}|~){0,1}(?:(?:\/|\\)(?:[a-zA-Z0-9._-])*)+|\w+:(?:\/?\/?)[^\s>]+)>?(?:\n? +[""'(](.*)[""')])?(?: \{(.*)\})?";
string input = @"|(?:\\|\/
[my label 1]: /foo/bar.jpg ""My title, optional""
[my label 2]: ~/foo/bar.png ""My title, optional""
[my label 1]: ~/foo/.img ""My title, optional""
[my label 1]: ~/.img ""My title, optional""
[my label 2]: /foo
[my label 3]: https://fsf.org (The free software foundation)
[my label 3]: (The free software foundation)
[my label 4]: /bar#special 'A title in single quotes'
[my label 1]: ./foo/bar.html ""My title, optional""
[my label 2]: ../foo/bar.html
[my label 1]: ./foo/bar.html ""My title, optional""
[my label 3]: https://fsf.org (The free software foundation)
[my label 4]: /foo/bar.html#special 'A title in single quotes'
[my label 5]: <http://foo.bar.baz>
[my label 3]: https://fsf.org
""The free software foundation""
[my label 5]: <http://foo.bar.baz>
[my label 1]: ..\foo\bar.html ""My title, optional""
[my label 1]: C:\foo\bar.html ""My title, optional""
[my label 1]: .\foo\bar.html ""My title, optional""
[my label 1]: \\unc.server.tld.co\path\to\file.ext ""My title, optional""
[my label 2]: C:\foo
[my label 3]: https://fsf.org (The free software foundation)
[my label 2]: /foo
[my label 3]: https://fsf.org (The free software foundation)
(?:\.{1,2}|~){0,1}(?:(?:\/|\\)(?:[a-zA-Z0-9._ -])*)+
^\[(?!\^)(.*)\]: <?((?:[a-zA-Z]\:|\\\\[^\/\\:*?""<>|]+\\[^\/\\:*?""<>|]+|\.{1,2})(?:\\[^\/\\:*?""<>|]+)+(?:\.[^\/\\:*?""<>| ]+)|(?:\.{1,2}|~){0,1}(?:(?:\/|\\)(?:[a-zA-Z0-9._ -])*)+|\w+:(?:\/?\/?)[^\s]+)>?(?:\n? +[""'(](.*)[""')])?(?: \{(.*)\})?";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}