const regex = /^\[(?!\^)(.*)\]: <?((?:[a-zA-Z]\:|\\\\[^\/\\:*?"<>|]+\\[^\/\\:*?"<>|]+|\.{1,2})(?:\\[^\/\\:*?"<>|]+)+(?:\.[^\/\\:*?"<>| ]+)|(?:\.{1,2}|~){0,1}(?:(?:\/|\\)(?:[a-zA-Z0-9._-])*)+|\w+:(?:\/?\/?)[^\s>]+)>?(?:\n? +["'(](.*)["')])?(?: \{(.*)\})?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\[(?!\\^)(.*)\\]: <?((?:[a-zA-Z]\\:|\\\\\\\\[^\\\/\\\\:*?"<>|]+\\\\[^\\\/\\\\:*?"<>|]+|\\.{1,2})(?:\\\\[^\\\/\\\\:*?"<>|]+)+(?:\\.[^\\\/\\\\:*?"<>| ]+)|(?:\\.{1,2}|~){0,1}(?:(?:\\\/|\\\\)(?:[a-zA-Z0-9._-])*)+|\\w+:(?:\\\/?\\\/?)[^\\s>]+)>?(?:\\n? +["\'(](.*)["\')])?(?: \\{(.*)\\})?', 'gm')
const str = `|(?:\\\\|\\/
[my label 1]: /foo/bar.jpg "My title, optional"
[my label 2]: ~/foo/bar.png "My title, optional"
[my label 1]: ~/foo/.img "My title, optional"
[my label 1]: ~/.img "My title, optional"
[my label 2]: /foo
[my label 3]: https://fsf.org (The free software foundation)
[my label 3]: (The free software foundation)
[my label 4]: /bar#special 'A title in single quotes'
[my label 1]: ./foo/bar.html "My title, optional"
[my label 2]: ../foo/bar.html
[my label 1]: ./foo/bar.html "My title, optional"
[my label 3]: https://fsf.org (The free software foundation)
[my label 4]: /foo/bar.html#special 'A title in single quotes'
[my label 5]: <http://foo.bar.baz>
[my label 3]: https://fsf.org
"The free software foundation"
[my label 5]: <http://foo.bar.baz>
[my label 1]: ..\\foo\\bar.html "My title, optional"
[my label 1]: C:\\foo\\bar.html "My title, optional"
[my label 1]: .\\foo\\bar.html "My title, optional"
[my label 1]: \\\\unc.server.tld.co\\path\\to\\file.ext "My title, optional"
[my label 2]: C:\\foo
[my label 3]: https://fsf.org (The free software foundation)
[my label 2]: /foo
[my label 3]: https://fsf.org (The free software foundation)
(?:\\.{1,2}|~){0,1}(?:(?:\\/|\\\\)(?:[a-zA-Z0-9._ -])*)+
^\\[(?!\\^)(.*)\\]: <?((?:[a-zA-Z]\\:|\\\\\\\\[^\\/\\\\:*?"<>|]+\\\\[^\\/\\\\:*?"<>|]+|\\.{1,2})(?:\\\\[^\\/\\\\:*?"<>|]+)+(?:\\.[^\\/\\\\:*?"<>| ]+)|(?:\\.{1,2}|~){0,1}(?:(?:\\/|\\\\)(?:[a-zA-Z0-9._ -])*)+|\\w+:(?:\\/?\\/?)[^\\s]+)>?(?:\\n? +["'(](.*)["')])?(?: \\{(.*)\\})?`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}