import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\[(?!\\^)(.*)\\]: <?((?:[a-zA-Z]\\:|\\\\\\\\[^\\/\\\\:*?\"<>|]+\\\\[^\\/\\\\:*?\"<>|]+|\\.{1,2})(?:\\\\[^\\/\\\\:*?\"<>|]+)+(?:\\.[^\\/\\\\:*?\"<>| ]+)|(?:\\.{1,2}|~){0,1}(?:(?:\\/|\\\\)(?:[a-zA-Z0-9._-])*)+|\\w+:(?:\\/?\\/?)[^\\s>]+)>?(?:\\n? +[\"'(](.*)[\"')])?(?: \\{(.*)\\})?";
final String string = "|(?:\\\\|\\/\n"
+ "[my label 1]: /foo/bar.jpg \"My title, optional\"\n"
+ "[my label 2]: ~/foo/bar.png \"My title, optional\"\n"
+ "[my label 1]: ~/foo/.img \"My title, optional\"\n"
+ "[my label 1]: ~/.img \"My title, optional\"\n\n"
+ "[my label 2]: /foo\n"
+ "[my label 3]: https://fsf.org (The free software foundation)\n"
+ "[my label 3]: (The free software foundation)\n\n"
+ "[my label 4]: /bar#special 'A title in single quotes'\n\n"
+ "[my label 1]: ./foo/bar.html \"My title, optional\"\n"
+ "[my label 2]: ../foo/bar.html\n"
+ "[my label 1]: ./foo/bar.html \"My title, optional\"\n"
+ "[my label 3]: https://fsf.org (The free software foundation)\n"
+ "[my label 4]: /foo/bar.html#special 'A title in single quotes'\n\n"
+ "[my label 5]: <http://foo.bar.baz>\n\n"
+ "[my label 3]: https://fsf.org\n"
+ " \"The free software foundation\"\n\n"
+ "[my label 5]: <http://foo.bar.baz>\n\n"
+ "[my label 1]: ..\\foo\\bar.html \"My title, optional\"\n"
+ "[my label 1]: C:\\foo\\bar.html \"My title, optional\"\n"
+ "[my label 1]: .\\foo\\bar.html \"My title, optional\"\n"
+ "[my label 1]: \\\\unc.server.tld.co\\path\\to\\file.ext \"My title, optional\"\n\n"
+ "[my label 2]: C:\\foo\n"
+ "[my label 3]: https://fsf.org (The free software foundation)\n\n\n"
+ "[my label 2]: /foo\n"
+ "[my label 3]: https://fsf.org (The free software foundation)\n\n"
+ "(?:\\.{1,2}|~){0,1}(?:(?:\\/|\\\\)(?:[a-zA-Z0-9._ -])*)+\n\n"
+ "^\\[(?!\\^)(.*)\\]: <?((?:[a-zA-Z]\\:|\\\\\\\\[^\\/\\\\:*?\"<>|]+\\\\[^\\/\\\\:*?\"<>|]+|\\.{1,2})(?:\\\\[^\\/\\\\:*?\"<>|]+)+(?:\\.[^\\/\\\\:*?\"<>| ]+)|(?:\\.{1,2}|~){0,1}(?:(?:\\/|\\\\)(?:[a-zA-Z0-9._ -])*)+|\\w+:(?:\\/?\\/?)[^\\s]+)>?(?:\\n? +[\"'(](.*)[\"')])?(?: \\{(.*)\\})?";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}