#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b(\d+)([a-zA-Z]+\d*)\b"
Local $sString = "1y" & @CRLF & _
"123y4" & @CRLF & _
"x_12y" & @CRLF & _
"1y + x_12y + 123y4"
Local $sSubst = "\1*\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)