use strict;
my $str = '1y
123y4
x_12y
1y + x_12y + 123y4';
my $regex = qr/\b(\d+)([a-zA-Z]+\d*)\b/mp;
my $subst = '\\1*\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";