using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(\d+)([a-zA-Z]+\d*)\b";
string substitution = @"\1*\2";
string input = @"1y
123y4
x_12y
1y + x_12y + 123y4";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}