const regex = new RegExp('\\b(\\d+)([a-zA-Z]+\\d*)\\b', 'gm')
const str = `1y
123y4
x_12y
1y + x_12y + 123y4`;
const subst = `\1*\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);