import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<down_payment>\\d+)\\s*(|\\$|dollars*|money)*\\s*(down|drive(\\s|-)*off|due\\s*at\\s*signing|drive\\s*-*\\s*off)*";
final String string = "monthly payment of 525 and 5000 drive off";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}