$re = '/(?P<down_payment>\d+)\s*(|\$|dollars*|money)*\s*(down|drive(\s|-)*off|due\s*at\s*signing|drive\s*-*\s*off)*/';
$str = 'monthly payment of 525 and 5000 drive off';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);