re = /(?P<down_payment>\d+)\s*(|\$|dollars*|money)*\s*(down|drive(\s|-)*off|due\s*at\s*signing|drive\s*-*\s*off)*/
str = 'monthly payment of 525 and 5000 drive off'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end