import re
regex = re.compile(r"(?P<down_payment>\d+)\s*(|\$|dollars*|money)*\s*(down|drive(\s|-)*off|due\s*at\s*signing|drive\s*-*\s*off)*")
test_str = "monthly payment of 525 and 5000 drive off"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")