package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-z_]+)[ ]*:=[ ]*'([^']*)';`)
var str = `unit Language.EN;
interface
uses
Winapi.Windows, System.SysUtils;
type
TDummyParent = record
private const
Languages: array [0 .. 2] of string = ('German', 'English');
public
class var a, b, c, d: string;
class procedure DummyProcedure; static;
end;
implementation
class procedure TDummyParent.DummyProcedure;
begin
a := 'string-a';
b := 'string-b';
c := sLineBreak + 'string-d';
d :=
'1 2 3 ' +
'4 5 6 ' +
'7 8 9';
end; `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}