use strict;
my $str = 'unit Language.EN;
interface
uses
Winapi.Windows, System.SysUtils;
type
TDummyParent = record
private const
Languages: array [0 .. 2] of string = (\'German\', \'English\');
public
class var a, b, c, d: string;
class procedure DummyProcedure; static;
end;
implementation
class procedure TDummyParent.DummyProcedure;
begin
a := \'string-a\';
b := \'string-b\';
c := sLineBreak + \'string-d\';
d :=
\'1 2 3 \' +
\'4 5 6 \' +
\'7 8 9\';
end; ';
my $regex = qr/([a-z_]+)[ ]*:=[ ]*'([^']*)';/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}