import Foundation
let pattern = #"([a-z_]+)[ ]*:=[ ]*'([^']*)';"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
unit Language.EN;
interface
uses
Winapi.Windows, System.SysUtils;
type
TDummyParent = record
private const
Languages: array [0 .. 2] of string = ('German', 'English');
public
class var a, b, c, d: string;
class procedure DummyProcedure; static;
end;
implementation
class procedure TDummyParent.DummyProcedure;
begin
a := 'string-a';
b := 'string-b';
c := sLineBreak + 'string-d';
d :=
'1 2 3 ' +
'4 5 6 ' +
'7 8 9';
end;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)